永遠的真田幸村
想讓Firefox 3能相容不支援的擴充套件?請試試Nightly Tester Tools
由 ivan 發表於 23:26, Mar 16, 2008 | 文章分類: 數位科技, software, www | 標籤列表: firefox |
網址: http://yblog.org/archive/index.php/Nightly_Tester_Tools_for_firefox3

隨著Firefox 3 Beta 4成功地改善Firefox瀏覽器在大量分頁與長時間使用下的記憶體耗用問題,Firefox 3 使用的人也越來越多,但用戶卻面臨著很多愛用、常用的附加元件(擴充套件;extension)不能用的情況,該怎麼辦呢?

Nightly Tester Tools是 一個相當好用的Firefox系列瀏覽器用擴充套件,能夠把不同時期Firefox版本瀏覽器中,與新版瀏覽器不相容的擴充套件設定成相容,這樣就能在新 版瀏覽器使用舊版的擴充套件了,減少Firefox新舊版本轉換上的落差。上一次大量使用是Firefox 1.5升級到Firefox 2.0系列的時候,而這次則是Firefox 2升級到Firefox 3的過渡階段。

安裝了這個套件,就能夠強制將Firefox 3認為不相容的套件設定成可以使用。不過,好用歸好用,有一些套件就算是設定成可以用,但Firefox 3不見得會買帳。

好 消息是,這種情況相當少,一般人常用的擴充套件,都是可以透過Nightly Tester Tools,選擇讓不相容的套件,直接make compatiable,讓Firefox 3認定這些擴充套件是可以用的,不過建議一個一個套件進行測試,而不是一次全部都設定成相容,減少找不出確切無法透過Nightly Tester Tools設定相容套件的情況。

未來等更多套件升級到Firefox 3相容後,慢慢地Nightly Tester Tools應該就不太會用到了。

怎麼樣設定Nightly Tester Tools來使用套件相容的功能呢?

先來看看Firefox 3碰到不支援套件,點選套件安裝後,會出現下面這樣的畫面。 

比方說Web Developer這個超好用的網頁開發人員輔助套件,還沒有推出支援Firefox 3的版本,就會有這樣的訊息。(最近則推出了支援firefox 3的版本了)

這樣一來,請先安裝Nightly Tester Tools, 重開Firefox瀏覽器後,開啟工具中的附加元件選單,點選 Nightly Tester Tools的偏好設定,在Add-ons分頁裡,選擇Disable add-on compatibility checking,將Firefox 3檢查套件相容性的功能關閉。

也可以選右下角的Make all  compatible,讓所有括套件都相容Firefox 3。

如此一來,重新回到Web Developer的畫面,就能夠正確進行安裝,不會顯示這個擴充套件不相容了。

安裝好套件後,重開機就可以發現Web Developer的工具列已經顯示在Firefox瀏覽器中,表示安裝成功。

 最後,如果你不是選擇上面提到的關閉檢查方式,也可以選擇下面的方式,在已經安裝且不相容的擴充套件清單中,點選滑鼠右鍵,選擇make compatible的功能,按下確定並重開Firefox 3後,這個套件也變得可以使用了。如果發現不能用,或造成Firefox 3運作不正常,再選擇將之關閉或移除會比較好,等待新版套件更新後再更新或安裝。

迴響留言
感謝你的說明

剛裝好ubuntu 8.04 裡面的firefox 就是 3.0版的

有些不相容的附加元件

正好用你說明的方式來讓它們相容

太好了
由 chenmin 發表於 3:33, Apr 26, 2008 | 61.172.2.*
不客氣,希望你用firefox 3能夠開心喔 ^^
由 ivan 發表於 1:49, Jun 23, 2008 | 208.97.143.*
Nightly Tester Tools。。請問這個下載回的檔案,要放在那個資料夾裡面!!
因為下載時沒有幫我直接安裝。。。麻煩你了!
由 MINWOO 發表於 13:02, Jun 21, 2008 | 61.230.187.*
妳只要放到硬碟裡,透過firefox的檔案工具列,選開啟,瀏覽妳剛下載的這個檔案xpi,點選開啟即可安裝。
由 ivan 發表於 1:49, Jun 23, 2008 | 208.97.143.*
Copyright Reserved.本站圖文內容原作者版權所有:yblog.org 若欲轉載請先徵求本站同意並標明出處